Una brutta notizia : QTQuick1 non è più disponibile dalla versione di QT 5.6

Era stato annunciato con la versione 5.5 che il modulo QtQuick1 non sarebbe più stato inserito nei sorgenti delle versioni successive … e così è stato.

Dal rilascio della 5.6 a Marzo 2016 solo pochi degli sviluppatori che utilizzano questo modulo su sistemi embedded con HMI senza accelerazione 3D hanno recepito l’importanza di questo cambio di rotta da parte di QT.

Ora si tratta di capire se per questi sviluppatori convenga di più rimanere fermi alla versione 5.5 per i prossimi anni in attesa di vedere l’ampliamento dell’offerta di microcontrollori con acceleratori OpenGLEs, oppure valutare il passaggio ad architetture più performanti.

E’ un peccato dover constatare che un modulo così semplice e performante su sistemi embedded di piccole dimensioni come quick1non possa avere un futuro all’interno di un frame work come QT.

Speriamo che qualche sviluppatore possa creare un fork di QtQuick1 per poterlo aggiungere come modulo esterno anche alle versioni future di QT, ma per questo si dovrà sicuramente aspettare qualche tempo.

Questo sito non utilizza cookie di profilazione, propri o di altri siti, finalizzati a visualizzare pubblicità in linea con le tue preferenze, ma utilizza cookies per la gestione delle funzionalità del sito stesso. Accedendo al sito dopo aver letto questo messaggio si acconsente all\\\'uso dei cookie. Dettagli | Chiudi